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TOPIC C
Consolidate Data
The ability to use 3-D references to summarize datasets with identical layouts is a powerful, handy
feature. But, what if you need to summarize data from datasets that aren't laid out in precisely the
same way? Or, what if you want to summarize data from a number of worksheets in different
workbooks? Life isn't always neat and tidy, and, unfortunately, the same can be said of workbook
data.
The good news is that Excel 2013 enables you to summarize data from multiple worksheets
regardless of whether or not the data is in the same location on each worksheet, or even if the
worksheets are in the same workbook. This means you can get a birds-eye view of your overall data
picture without having to painstakingly copy and paste your raw data into the same workbook and
modify the layout so that it all matches.

Data Consolidation
Data consolidation is the act of summarizing data when it isn't neatly packaged in a table or PivotTable,
and when it isn't necessarily entered into multiple worksheets in precisely the same location. Excel
2013 enables you to consolidate data based on either relative cell positions in the various source
datasets or by categories, which are based on row and column labels. You can summarize
consolidated data by using any of the summary functions available in Excel.
Although source datasets don't have to be in precisely the same location on all worksheets, or even
contain the same number of columns or rows, it's a best practice to ensure your data is structured in
approximately the same manner. For example, if you consolidate data by category using column
labels as the category indicators, the columns don't have to appear in the same location within the
various sources and the columns don't even have to appear in the same order, but the various
datasets should include the same column labels. And all data ranges that you enter into a
consolidated dataset by category must be contiguous, meaning there can be no empty rows or
columns. If your original data is non-contiguous, you can consolidate it by using relative cell
positions as long as you enter each non-contiguous range separately.
You have the option of linking your consolidated dataset to the original data sources. This way, your
consolidated dataset will update whenever the original source data is updated. Keep in mind,
however, that if you link your consolidated data to the sources, Excel automatically creates the
consolidated dataset as an outline with the detail entries collapsed.

Figure 1-7: Excel creates consolidated datasets that are linked to the source data as outlines.

The Consolidate Dialog Box
You use the Consolidate dialog box to determine which source datasets Excel will summarize in
the consolidated dataset, which summary function it will use to summarize the data, and how it will
organize the consolidated dataset. You can access the Consolidate dialog box by selecting
DATA→Data Tools→Consolidate.
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The Consolidate Dialog
Box



Figure 1-8: The Consolidate dialog box.

The following table describes the various elements of the Consolidate dialog box.

Consolidate Dialog Box Element Description

Function drop-down menu Use this to select the summary function Excel will use to
consolidate the source data.

Reference field Use this to enter each range of data you wish to add to the
consolidated dataset.

All references list Displays a list of all of the ranges included in the
consolidated dataset.

Browse button Opens the Browse dialog box, enabling you to search for
workbook files that aren't currently open to include in the
consolidated dataset.

Add button Adds the range currently displayed in the Reference field
to the All references list.

Delete button Removes the currently selected range reference from the
All references list.

Top row check box Check this if you include column labels in your source data
ranges and you want Excel to organize your consolidated
dataset by category according to the column labels.

Left column check box Check this if you include row labels in your source data
ranges and you want Excel to organize your consolidated
dataset by category according to the row labels.

Create links to source data check
box

Check this if you want Excel to create links to the source
data in the consolidated dataset. Linking the consolidated
dataset automatically structures it as an outline.
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Note: If you want Excel to use both column and row labels to organize the consolidated dataset
by category, check both the Top row and the Left column check boxes. You must include both
column and row labels in the source data ranges to do this. If you want Excel to organize the
consolidated dataset according to relative cell positions within the source datasets, leave both of
these check boxes unchecked.

Access the Checklist tile on your LogicalCHOICE course screen for reference
information and job aids on How to Consolidate Data.
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ACTIVITY 1-3
Consolidating Data

Data Files
C:\091053Data\Working with Multiple Worksheets and Workbooks Simultaneously
\monthly_sales_2006-10.xlsx
C:\091053Data\Working with Multiple Worksheets and Workbooks Simultaneously
\monthly_sales_2011-15.xlsx

Before You Begin
Excel 2013 is open.

Scenario
For the upcoming sales meeting, your supervisor has requested that you present average and total
sales figures for each of Fuller and Ackerman's markets on a per-month basis for a period of five
years. The data is stored in workbooks that cover five-year periods, with each calendar year
represented on a separate worksheet. Because you're looking for the period 2008 through 2012,
you'll need to consolidate data from two different workbooks. While reviewing the monthly sales
workbooks, you notice someone has apparently sorted the data on several of the worksheets by row
and by column, which means you can't use 3-D references to summarize the data. You decide
consolidating by both row and column labels will be your best option. As these sales figures are all
approved and final, you decide not to link the consolidated data to the source data ranges; it is
unlikely these will change.

1. Open the monthly_sales_2006-10.xlsx and the monthly_sales_2011-15.xlsx workbook files.

2. Create a new blank workbook.

3. In the new blank workbook, ensure that cell A1 is selected, type 2008-12 Average Sales by Market and
then press Enter.

4. Select cell A3 and then select DATA→Data Tools→Consolidate.

Note: This course uses a streamlined notation for ribbon commands. They'll
appear as "[Ribbon Tab]→[Group]→[Button or Control]" as in "Select
HOME→Clipboard→Paste." If the group name isn't needed for navigation or there
isn't a group, it's omitted, as in "Select FILE→Open." For selections that open
menus and submenus, this notation convention will continue until you are
directed to select the final command or option, as in "Select
HOME→Cells→Format→Hide & Unhide→Hide Rows."

Note: Some Excel 2013 command buttons are split, meaning there are actually
two separate buttons you can select independently. This is often the case with
commands that have multiple options/variations accessible by selecting a drop-
down arrow. The Paste command button in the Clipboard group on the HOME
tab is an example of this. For these commands, you will be directed to either
select just the button, as in "Select HOME→Clipboard→Paste," or you will be
directed to select the drop-down arrow if necessary, as in "Select
HOME→Clipboard→Paste drop-down arrow→Paste Special."
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5. In the Consolidate dialog box, from the Function drop-down menu, select Average.

6. Add the source data ranges for the years 2008 through 2012.

a) In the Reference field, select the Collapse Dialog button. 
b) Switch to the monthly_sales_2006-10.xlsx workbook and select the 2008 worksheet tab.
c) Select the range A1:M5 and then press Enter.
d) In the Consolidate dialog box, select Add.

e) In the Reference field, select the Collapse Dialog button,  select the 2009 worksheet tab, select
the range A1:M5, press Enter, and then select Add.

f) Repeat the process to add the source data from the 2010 worksheet tab.

g) Select the Collapse Dialog button,  switch to the monthly_sales_2011-15.xlsx workbook, and
ensure that the 2011 worksheet tab is selected.

Note: You may need to first clear any existing text from the Reference field
before switching to the monthly_sales_2011-15.xlsx workbook. Try this if Excel
keeps reverting back to the monthly_sales_2006-10.xlsx workbook.

h) Select the range A1:M5, press Enter, and select Add.
i) Repeat the process to add the source data from the 2012 worksheet tab.
j) In the All references list, scroll up or down as necessary to verify all five sets of data have been

added to the consolidation.

7. Consolidate the data.
a) In the Consolidate dialog box, check the Top row and the Left column check boxes.

 

 
b) Select OK.
c) If necessary, switch back to the newly created workbook.
d) Select HOME→Cells→Format→AutoFit Column Width to adjust all columns to accommodate the

data.

8. Review the average monthly sales data in the new workbook.
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Let the students know
they don't have to re-
select the
monthly_sales_2006-10.
xlsx workbook in steps
6e and 6f. Excel will
automatically look to the
same workbook.

You may wish to let the
students know that there
are other methods of
resizing the columns.
For example, they could
select the Select All
button to select all cells
and then double-click
the border between any
two column headers.



 

9. Calculate the total sales figures for the same five-year period broken out by month.
a) Select cell A9, type 2008-12 Total Sales by Market, and press Enter.
b) Select cell A11.
c) Select DATA→Data Tools→Consolidate.
d) In the Consolidate dialog box, from the Function drop-down menu, select Sum.
e) Select OK.
f) Review the total monthly sales data.

 

 

10. Save the workbook to the C:\091053\Working with Multiple Worksheets and Workbooks Simultaneously
folder as my_monthly_sales_consolidated.xlsx

11. Close all open workbooks.

20  |  Microsoft® Office Excel® 2013: Part 3 (Second Edition)

Lesson 1: Working with Multiple Worksheets and Workbooks Simultaneously  |  Topic C

Point out to the students
that all of the data
ranges still appear in the
All references list. They
do not have to add them
again.



Summary
In this lesson, you worked with a number of worksheets and workbooks simultaneously in order to
analyze data from a variety of sources in a single location. By taking advantage of Excel's ability to
reference data from a variety of sources, you'll capture the full potential of the wide range of data
available in your organization. And, you'll do so without the extra time and effort it would take to
manually copy or move the source data, a task that could be nearly impossible in large organizations.
In addition to saving time and effort, you'll also ensure that errors are kept to a minimum,
maintaining the integrity of both your raw data and your analysis.

Which method of simultaneously working with multiple worksheets and workbooks do you think will help
you the most with your daily tasks? Why?

A: Answers will vary depending on the students' roles. People who frequently work with workbooks that
are laid out and formatted in exactly the same way will likely find 3-D references highly useful. People
who often collaborate on workbooks that are frequently sorted and filtered will find the data
consolidation feature handy. And, people who need to draw data from a wide variety of source
workbooks from a large number of departments or teams, financial analysts, for example, may find
links and external references preferable.

Can you think of a time when having your workbook cells linked to the source data would have saved you
time, effort, and hassle?

A: Answers may vary, but many users have probably experienced the frustration of having to re-enter
data and manually check entries for accuracy after last-minute updates or data revisions.

Note: Check your LogicalCHOICE Course screen for opportunities to interact with your
classmates, peers, and the larger LogicalCHOICE online community about the topics covered in
this course or other topics you are interested in. From the Course screen you can also access
available resources for a more continuous learning experience.
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Encourage students to
use the social
networking tools
provided on the
LogicalCHOICE Home
screen to follow up with
their peers after the
course is completed for
further discussion and
resources to support
continued learning.




