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The building blocks of an InDesign layout are objects, 
text, and graphics. Layout aids such as guides help 
with size and placement, and styles let you format 
page elements automatically. 
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Getting started
The document for this lesson is a standard-size postcard designed to be printed and 
mailed. In addition, the postcard can be exported as a PDF to use in email marketing. 
As you will see in this lesson, the building blocks of an InDesign document are the 
same, regardless of the output media. In this lesson, you will add the text, images, 
and formatting necessary to finish the 6" x 4.25" postcard. 

1 To ensure that the preference and default settings of your Adobe InDesign 
program match those used in this lesson, move the InDesign Defaults file to a 
different folder following the procedure in “Saving and restoring the InDesign 
Defaults file” on page 3. 

2 Start Adobe InDesign. 

3 To ensure that the panels and menu commands match those used in this lesson, 
choose Window > Workspace > [Advanced], and then choose Window > 
Workspace > Reset Advanced. 

4 Click the Go To Bridge button ( ) in the Application bar at the top of the 
document window. 

You will use Adobe Bridge, the media manager that comes with InDesign, to open  
a document and view details about it.

5 In the Folders panel in Adobe Bridge, locate and click the Lesson02 folder, located 
inside the Lessons folder within the InDesignCIB folder on your hard drive.

6 In the Content panel, in the middle of the Adobe Bridge window, click the 02_
End.indd file. The Metadata panel to the right displays details about the 02_End.
indd file.

By scrolling through the Metadata panel, you can view information about the 
selected document, including colors, fonts, version of InDesign used to create it, 
and more. You can scale the preview thumbnails in the Content panel by using the 
Thumbnail slider at the bottom of the Adobe Bridge window.

 Note: If you have  
not already downloaded  
the project files for this  
lesson to your computer 
from your Account page, 
make sure to do so now. 
See “Getting Started”  
at the beginning of  
the book.

	Note: Adobe Bridge 
is a separate application 
that is available to 
InDesign Creative Cloud 
users.
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7 Double-click the 02_End.indd file in Adobe Bridge to open it. Leave this file open 
to act as a guide for working on the lesson document. 

8 To open the lesson document, a half-finished postcard, choose File > Open. 

9 Open the 02_Start.indd file, in the Lesson02 folder, located inside the Lessons 
folder within the InDesignCIB folder on your hard disk.

10 Choose File > Save As, rename the file 02_Postcard.indd, and save it in the 
Lesson02 folder.

Viewing guides
Revising or completing an existing document, as you will do in this lesson, is very 
typical work for entry-level InDesign users. Currently, the postcard document is 
displayed in Preview mode, which displays artwork in a standard window, hiding 
nonprinting elements such as guides, grids, frame edges, and hidden characters. To 
work on this document, you will view guides and hidden characters (such as spaces 
and tabs). As you become comfortable working with InDesign, you will discover 
which view modes and layout aids work best for you.

 1 Click and hold down the Screen Mode button at the 
bottom of the Tools panel, and choose Normal ( )  
from the menu. 

Any layout aids that are enabled now display. For example, 
light blue, nonprinting lines now indicate existing text frames 
and objects because Frame Edges were displayed (View > 
Extras). You will now enable other layout aids. 

�	Tip: The other 
view modes are Bleed, 
for reviewing the 
predefined bleed area 
that extends beyond 
the page boundaries; 
Slug, for displaying the 
area outside the bleed 
area that can contain 
information such as 
printer instructions or 
job sign-off information; 
and Presentation, 
which fills the screen 
and works well for 
presenting design ideas 
to clients. 
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2 In the Application bar, click the View Options menu ( ) and select Guides.  
Be sure Guides is checked in the menu. You can also choose View > Grids & 
Guides > Show Guides.

When guides are displayed, it’s easy to place text and objects with precision, including 
automatically snapping them into place. The guides do not print and do not limit the 
print or export area. 

3 From the same View Options menu, choose Hidden Characters. You can also 
choose Type > Show Hidden Characters. 

Displaying hidden (nonprinting) characters, such as tabs, spaces, and paragraph 
returns, helps you precisely select and style text. In general, it’s a good idea to show 
hidden characters whenever you are editing or formatting text.

4 As you work on this document, use the skills you learned in Lesson 1 to move 
panels, rearrange panels, scroll, and zoom as necessary.

Preflighting as you work
Anytime you start working on a document for the first time—whether you’re creating 
a document from scratch or revising an existing document—you will need to keep 
an eye on output issues. You will learn more about all of these issues throughout the 
 lessons in this book. Common issues include: 

• Missing fonts: If a font used in the document is not present or enabled on your 
system, it is considered missing and the document will not print properly. 

• Color models: Colors created in the wrong color model for the intended output 
device can cause problems. A common problem is that digital camera images 
often use the RGB color model while offset printing requires CMYK colors.  

• Overset text: As text formatting changes and objects are moved and resized 
during layout, text can accidentally get cut off so it doesn’t display or print. This 
is referred to as overset text.
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In publishing, the process of reviewing a document for output issues is known  
as preflighting. InDesign provides a Live Preflight feature that lets you monitor 
documents as you’re working to prevent potential problems from occurring. To 
customize Live Preflight, you can create or import production rules (called profiles) 
against which to check your documents. The default profile supplied with InDesign 
flags issues such as missing fonts and overset text (text that does not fit in its text 
frame). You will fix an overset text error in this exercise.

1 Choose Window > Output > Preflight to open the Preflight panel. 

Using the [Basic] (Working) preflight  
profile, InDesign finds one error, as 
indicated by the red Preflight icon ( ), 
which displays in the lower-left corner 
of the Preflight panel and the document 
window. According to the Error list in 
the Preflight panel, the problem is Text. 

2 To view the error, click the arrow 
next to Text in the Preflight panel.

3 Click the arrow next to Overset Text, 
and then click Text Frame.

4 To display details for the error, click 
the arrow next to Info below.

5 Double-click Text Frame to select 
the problem text frame on the page. 

The text frame containing the red text that starts with “Cobblers, crumbles, crisps” 
is selected. The overset text is indicated by a red plus sign (+) in the frame’s out port 
(the small square just above the lower-right corner of the frame). 

6 Using the Selection tool ( ), drag the handle at the bottom of the text frame 
down until it touches the ruler guide. 

7 Click the pasteboard to deselect the text frame. 

8 Choose View > Fit Page In Window. 

�	Tip: You can handle 
overset text in various 
ways, including revising 
the text in the Story 
Editor, reducing the font 
size, or expanding the 
text frame. 

�	Tip: Ruler guides 
are cyan, a blue-green 
color, by default.
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InDesign now reports No Errors in the Preflight panel and the lower-left corner of 
the document window.

9 Close the Preflight panel. Choose File > Save to save your work.

Adding text
With InDesign, most text is contained by a text frame. (Text can also be contained 
in table cells and flow along paths.) You can type text directly into a text frame 
or import text files from word-processing programs. When importing text files, 
you can add the text to existing frames or create frames to contain the text. If text 
doesn’t fit within the same frame, you can “thread,” or link, the text frames. 

typing and styling text
You’re ready to start working on the incomplete postcard. First, you’ll type text in a 
text frame shaped like a “speech balloon.” Then, you will format the text and adjust 
its placement within the frame. 

1 Select the Type tool ( ), and click in the speech balloon at right.

2 Type Berries are not born in a box. in the text frame.

3 With the insertion point still in the text, choose Edit > Select All.

4 If necessary, click the Character Formatting Controls icon ( ) in the Control 
panel. Using the controls at far left, do the following:

• From the Font Family menu, select Myriad Pro. 

• From Font Style menu, select Regular (if necessary).

• Type 7 in the Font Size box to the right of the Font Family menu.

• Type 6 in the Leading box under the Font Size box.

�	Tip: Keep an eye on 
the lower-left corner of 
the document window 
to see if any errors arise. 
You can double-click 
the red Preflight icon (

) to open the Preflight 
panel for details on any 
errors. 

�	Tip: Use the Type 
tool to edit text, format 
text, and create new 
text frames.
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5 Towards the middle of the Control panel, click the Center button ( ). 

You will now set an option for the text frame to control how the text is positioned 
vertically within the frame. 

6 With the text frame still selected, choose Object > Text Frame Options. Select 
the General tab (if necessary).

7 In the Vertical Justification section, select Center from the Align menu. 

Note the location of the Columns and Inset Spacing features, which are helpful for 
positioning text within a frame as well. You will use these in later lessons.

8 Select the Preview box in the lower-left corner, to see the change, and then  
click OK. 

    

9 Choose File > Save to save your work.

importing and flowing text
In most publishing workflows, writers and editors use word processors. When the 
text is almost final, they send the files to graphic designers. To complete the post-
card, you will import a Microsoft Word file into a text frame at the bottom of the 
page using the Place command. You will then link the first text frame to the other 
two frames using a process called “threading.” 

1 Make sure that no objects are selected by clicking a blank area of the pasteboard.

2 Choose File > Place. At the bottom of the Place dialog box, make sure that Show 
Import Options is not selected.

3 Navigate to the Lesson02 folder, in the Lessons folder, and double-click the 
BerryFarms.docx file.

�	Tip: Alignments 
such as Center are 
paragraph formats, but 
they still display in the 
Control panel when 
Character Formatting 
Controls are displayed. 
Select Paragraph 
Formatting Controls 
to display paragraph 
formats more 
conveniently at left.

�	Tip: In many pub-
lishing environments, 
including marketing 
and advertising, the  
text is referred to as 
“copy,” which is why the 
writers and editors are 
called “copywriters” and 
“copy editors.” 
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The pointer changes to a loaded text icon ( ). You’ll add this text to the text frame 
in the lower-left quadrant of the postcard. (The text frames are outlined by light blue 
nonprinting lines.)

4 Position the loaded text icon  
in the upper-left corner of 
the text frame, then click. 

The text in the Word file fills 
the frame, but it doesn’t all fit. 
A red plus sign (+) in the out 
port of the frame indicates overset text. You will thread these text frames so the text 
flows through them. 

5 Using the Selection tool ( ), select the text frame that now contains the text. 

6 Click the out port in the lower-right corner of the selected frame. The pointer 
becomes a loaded text icon. Click in the text frame immediately to the right. 

7 Once the text flows into the middle text frame, click that frame’s out port.  
The pointer again becomes a loaded text icon. Click in the remaining text  
frame to finish threading the frames.

At this point, text is still overset and the apple-shaped object is overlapping the  
text.  You will resolve these problems by formatting the text with styles and  
wrapping the text around the apple shape later in this lesson. 

8 Choose File > Save.

	Note: To see where 
to place the body 
copy text, consult 
the finished lesson 
document, 02_End.indd. 

�	Tip: When you have 
a loaded text icon, you 
have several choices: 
You can drag to create 
a new text frame, click 
inside an existing frame, 
or click to create a new 
text frame within the 
page’s column guides.

	Note: Due to 
variations in font 
versions, you may see 
slightly different text  
in your frames. 
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